Oct 15, 20:48 CET
Fixed - We have implemented a fix.
Oct 15, 20:44 CET
Identified - We have identified a dDoS attack that is affecting one of our two main firewalls and one switch, causing issue to servers and services behind this infrastructure. We are in the process of implementing a fix and mitigating measures.