Server24 Control PanelStorage-Unit CloudStorage1 offline
Jul 12, 04:00 CET
Fixed - The storage unit has been restored without data loss.
Jul 12, 00:00 CET
Investigating - Server24 is investigating the outage of the storage unit CloudStorage1 which is causing outages for the Server24 Control Panel.